package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#(\d+) @ (\d+),(\d+): (\d+)x(\d+)`)
var str = `#1 @ 338,764: 20x24
#2 @ 80,667: 12x26
#3 @ 625,36: 17x22
#4 @ 196,235: 25x13
#5 @ 610,700: 25x21
#6 @ 590,831: 20x13
#7 @ 253,201: 29x22
#8 @ 921,577: 15x13
#9 @ 495,85: 20x19
#10 @ 397,589: 17x22`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}