import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#(\\d+) @ (\\d+),(\\d+): (\\d+)x(\\d+)";
final String string = "#1 @ 338,764: 20x24\n"
+ "#2 @ 80,667: 12x26\n"
+ "#3 @ 625,36: 17x22\n"
+ "#4 @ 196,235: 25x13\n"
+ "#5 @ 610,700: 25x21\n"
+ "#6 @ 590,831: 20x13\n"
+ "#7 @ 253,201: 29x22\n"
+ "#8 @ 921,577: 15x13\n"
+ "#9 @ 495,85: 20x19\n"
+ "#10 @ 397,589: 17x22";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}