re = /#(\d+) @ (\d+),(\d+): (\d+)x(\d+)/
str = '#1 @ 338,764: 20x24
#2 @ 80,667: 12x26
#3 @ 625,36: 17x22
#4 @ 196,235: 25x13
#5 @ 610,700: 25x21
#6 @ 590,831: 20x13
#7 @ 253,201: 29x22
#8 @ 921,577: 15x13
#9 @ 495,85: 20x19
#10 @ 397,589: 17x22'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end