#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:\b([a-z]++)\B|\G(?<!^))([A-Z][a-z]+|[a-z]+|[A-Z]+)"
Local $sString = "parsingHTTPorSomeURLrequestToday enhanceThisGold thisIsCOOL xP anotherACRONYMiTest loadedTHISupLIKEaMaDmAnS NoReplacement NONEok None none n "
Local $sSubst = "\L$1_$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)