use strict;
my $str = 'parsingHTTPorSomeURLrequestToday enhanceThisGold thisIsCOOL xP anotherACRONYMiTest loadedTHISupLIKEaMaDmAnS NoReplacement NONEok None none n ';
my $regex = qr/(?:\b([a-z]++)\B|\G(?<!^))([A-Z][a-z]+|[a-z]+|[A-Z]+)/p;
my $subst = '\\L$1_$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";