const regex = /(?:\b([a-z]++)\B|\G(?<!^))([A-Z][a-z]+|[a-z]+|[A-Z]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b([a-z]++)\\B|\\G(?<!^))([A-Z][a-z]+|[a-z]+|[A-Z]+)', 'g')
const str = `parsingHTTPorSomeURLrequestToday enhanceThisGold thisIsCOOL xP anotherACRONYMiTest loadedTHISupLIKEaMaDmAnS NoReplacement NONEok None none n `;
const subst = `\L$1_$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);