re = /(?:\b([a-z]++)\B|\G(?<!^))([A-Z][a-z]+|[a-z]+|[A-Z]+)/
str = 'parsingHTTPorSomeURLrequestToday enhanceThisGold thisIsCOOL xP anotherACRONYMiTest loadedTHISupLIKEaMaDmAnS NoReplacement NONEok None none n '
subst = '\\L$1_$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result