import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\b([a-z]++)\\B|\\G(?<!^))([A-Z][a-z]+|[a-z]+|[A-Z]+)";
final String string = "parsingHTTPorSomeURLrequestToday enhanceThisGold thisIsCOOL xP anotherACRONYMiTest loadedTHISupLIKEaMaDmAnS NoReplacement NONEok None none n ";
final String subst = "\\L$1_$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}