import Foundation
let pattern = #"(?:\b([a-z]++)\B|\G(?<!^))([A-Z][a-z]+|[a-z]+|[A-Z]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"parsingHTTPorSomeURLrequestToday enhanceThisGold thisIsCOOL xP anotherACRONYMiTest loadedTHISupLIKEaMaDmAnS NoReplacement NONEok None none n "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\L$1_$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)