using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([02-9]\.[0-9])|([0-9]\.[013-9]))\.[0-9]
";
string input = @"<Tag Id1=""1.1.1-text"" Id2=""1.1.2-text"" Id3=""1.2.3-text"" />";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}