package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(([02-9]\.[0-9])|([0-9]\.[013-9]))\.[0-9]
`)
var str = `<Tag Id1="1.1.1-text" Id2="1.1.2-text" Id3="1.2.3-text" />`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}