$re = '/(([02-9]\.[0-9])|([0-9]\.[013-9]))\.[0-9]
/m';
$str = '<Tag Id1="1.1.1-text" Id2="1.1.2-text" Id3="1.2.3-text" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);