// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(([02-9]\.[0-9])|([0-9]\.[013-9]))\.[0-9]
").unwrap();
let string = "<Tag Id1=\"1.1.1-text\" Id2=\"1.1.2-text\" Id3=\"1.2.3-text\" />";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}