import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([02-9]\\.[0-9])|([0-9]\\.[013-9]))\\.[0-9]\n";
final String string = "<Tag Id1=\"1.1.1-text\" Id2=\"1.1.2-text\" Id3=\"1.2.3-text\" />";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}