use strict;
my $str = '<Tag Id1="1.1.1-text" Id2="1.1.2-text" Id3="1.2.3-text" />';
my $regex = qr/(([02-9]\.[0-9])|([0-9]\.[013-9]))\.[0-9]
/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}