#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\*+(?= +\S)|(?<! )(?<!\*(?=\S)[^*\n]*)(\*+)(?![\w*])"
Local $sString = "Input => Actual === Expected : Success" & @CRLF & _
"=========================================================================" & @CRLF & _
"A b*** c => A b³ c === A b³ c : true" & @CRLF & _
"A *b* c* => A *b* c¹ === A *b* c¹ : true" & @CRLF & _
"A *b* *c* d* => A *b* *c* d¹ === A *b* *c* d¹ : true" & @CRLF & _
"A *b* c* d** => A *b* c¹ d² === A *b* c¹ d² : true" & @CRLF & _
"** a b c => ² a b c === ² a b c : true" & @CRLF & _
"** a b*** c => ² a b³ c === ² a b³ c : true" & @CRLF & _
"A *bc* d** => A *bc* d** === A *bc* d² : false"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")