re = /^\*+(?= +\S)|(?<! )(?<!\*(?=\S)[^*\n]*)(\*+)(?![\w*])/
str = 'Input => Actual === Expected : Success
=========================================================================
A b*** c => A b³ c === A b³ c : true
A *b* c* => A *b* c¹ === A *b* c¹ : true
A *b* *c* d* => A *b* *c* d¹ === A *b* *c* d¹ : true
A *b* c* d** => A *b* c¹ d² === A *b* c¹ d² : true
** a b c => ² a b c === ² a b c : true
** a b*** c => ² a b³ c === ² a b³ c : true
A *bc* d** => A *bc* d** === A *bc* d² : false'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end