import Foundation
let pattern = #"^\*+(?= +\S)|(?<! )(?<!\*(?=\S)[^*\n]*)(\*+)(?![\w*])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Input => Actual === Expected : Success
=========================================================================
A b*** c => A b³ c === A b³ c : true
A *b* c* => A *b* c¹ === A *b* c¹ : true
A *b* *c* d* => A *b* *c* d¹ === A *b* *c* d¹ : true
A *b* c* d** => A *b* c¹ d² === A *b* c¹ d² : true
** a b c => ² a b c === ² a b c : true
** a b*** c => ² a b³ c === ² a b³ c : true
A *bc* d** => A *bc* d** === A *bc* d² : false
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)