use strict;
my $str = 'Input => Actual === Expected : Success
=========================================================================
A b*** c => A b³ c === A b³ c : true
A *b* c* => A *b* c¹ === A *b* c¹ : true
A *b* *c* d* => A *b* *c* d¹ === A *b* *c* d¹ : true
A *b* c* d** => A *b* c¹ d² === A *b* c¹ d² : true
** a b c => ² a b c === ² a b c : true
** a b*** c => ² a b³ c === ² a b³ c : true
A *bc* d** => A *bc* d** === A *bc* d² : false';
my $regex = qr/^\*+(?= +\S)|(?<! )(?<!\*(?=\S)[^*\n]*)(\*+)(?![\w*])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}