import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\*+(?= +\\S)|(?<! )(?<!\\*(?=\\S)[^*\\n]*)(\\*+)(?![\\w*])";
final String string = "Input => Actual === Expected : Success\n"
+ "=========================================================================\n"
+ "A b*** c => A b³ c === A b³ c : true\n"
+ "A *b* c* => A *b* c¹ === A *b* c¹ : true\n"
+ "A *b* *c* d* => A *b* *c* d¹ === A *b* *c* d¹ : true\n"
+ "A *b* c* d** => A *b* c¹ d² === A *b* c¹ d² : true\n"
+ "** a b c => ² a b c === ² a b c : true\n"
+ "** a b*** c => ² a b³ c === ² a b³ c : true\n"
+ "A *bc* d** => A *bc* d** === A *bc* d² : false";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}