#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[\w\.\-]+$"
Local $sString = "Examples of valid names:" & @CRLF & _
"" & @CRLF & _
"foo" & @CRLF & _
"foo_bar" & @CRLF & _
"foo-bar" & @CRLF & _
"" & @CRLF & _
"Examples of invalid names:" & @CRLF & _
"" & @CRLF & _
"foo bar" & @CRLF & _
"foo@bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")