$re = '`^[\w\.\-]+$`mi';
$str = 'Examples of valid names:
foo
foo_bar
foo-bar
Examples of invalid names:
foo bar
foo@bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);