re = /^[\w\.\-]+$/mi
str = 'Examples of valid names:
foo
foo_bar
foo-bar
Examples of invalid names:
foo bar
foo@bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end