// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^[\w\.\-]+$").unwrap();
let string = "Examples of valid names:
foo
foo_bar
foo-bar
Examples of invalid names:
foo bar
foo@bar";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}