package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[\w\.\-]+$`)
var str = `Examples of valid names:
foo
foo_bar
foo-bar
Examples of invalid names:
foo bar
foo@bar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}