#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?=(?!^)[^\[\]]*?\[|[^\[\]]+$)"
Local $sString = "ABCDE[NOT]FGH" & @CRLF & _
"CCGF[NOT]HI" & @CRLF & _
"MPJ[NOT]L" & @CRLF & _
"MNA[NOT]PLJ[KAJ]SHD" & @CRLF & _
"MPJ[NOT]" & @CRLF & _
"[NOT]L" & @CRLF & _
"MNA[NOT]PLJ[KAJ]SHDMNA[NOT]PLJ[KAJ]SHDMNA[NOT]PLJ[KAJ]" & @CRLF & _
"MNA[NOT]PLJ[KAJ]SHDMNA[NOT]PLJ[KAJ]SHDMNA[NOT][KAJ]"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)