const regex = new RegExp('(?=(?!^)[^\\[\\]]*?\\[|[^\\[\\]]+$)', 'gm')
const str = `ABCDE[NOT]FGH
CCGF[NOT]HI
MPJ[NOT]L
MNA[NOT]PLJ[KAJ]SHD
MPJ[NOT]
[NOT]L
MNA[NOT]PLJ[KAJ]SHDMNA[NOT]PLJ[KAJ]SHDMNA[NOT]PLJ[KAJ]
MNA[NOT]PLJ[KAJ]SHDMNA[NOT]PLJ[KAJ]SHDMNA[NOT][KAJ]`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);