import re
regex = re.compile(r"(?=(?!^)[^\[\]]*?\[|[^\[\]]+$)", flags=re.MULTILINE)
test_str = ("ABCDE[NOT]FGH\n"
"CCGF[NOT]HI\n"
"MPJ[NOT]L\n"
"MNA[NOT]PLJ[KAJ]SHD\n"
"MPJ[NOT]\n"
"[NOT]L\n"
"MNA[NOT]PLJ[KAJ]SHDMNA[NOT]PLJ[KAJ]SHDMNA[NOT]PLJ[KAJ]\n"
"MNA[NOT]PLJ[KAJ]SHDMNA[NOT]PLJ[KAJ]SHDMNA[NOT][KAJ]")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)