use strict;
my $str = 'ABCDE[NOT]FGH
CCGF[NOT]HI
MPJ[NOT]L
MNA[NOT]PLJ[KAJ]SHD
MPJ[NOT]
[NOT]L
MNA[NOT]PLJ[KAJ]SHDMNA[NOT]PLJ[KAJ]SHDMNA[NOT]PLJ[KAJ]
MNA[NOT]PLJ[KAJ]SHDMNA[NOT]PLJ[KAJ]SHDMNA[NOT][KAJ]';
my $regex = qr/(?=(?!^)[^\[\]]*?\[|[^\[\]]+$)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";