import Foundation
let pattern = #"(?=(?!^)[^\[\]]*?\[|[^\[\]]+$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ABCDE[NOT]FGH
CCGF[NOT]HI
MPJ[NOT]L
MNA[NOT]PLJ[KAJ]SHD
MPJ[NOT]
[NOT]L
MNA[NOT]PLJ[KAJ]SHDMNA[NOT]PLJ[KAJ]SHDMNA[NOT]PLJ[KAJ]
MNA[NOT]PLJ[KAJ]SHDMNA[NOT]PLJ[KAJ]SHDMNA[NOT][KAJ]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)