#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-Z]{2}\d{4})(?!-\d)(L\d|Transit|T$)?"
Local $sString = "AB1201" & @CRLF & _
"AB-1201" & @CRLF & _
"AB1201-T" & @CRLF & _
"AB-12-01L1" & @CRLF & _
"AB1201-TER" & @CRLF & _
"AB1201 Transit" & @CRLF & _
"AB1201EFH" & @CRLF & _
"AB1201-02" & @CRLF & _
"AB1201-EFH"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")