import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z]{2}\\d{4})(?!-\\d)(L\\d|Transit|T$)?";
final String string = "AB1201\n"
+ "AB-1201\n"
+ "AB1201-T\n"
+ "AB-12-01L1\n"
+ "AB1201-TER\n"
+ "AB1201 Transit\n"
+ "AB1201EFH\n"
+ "AB1201-02\n"
+ "AB1201-EFH";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}