use strict;
my $str = 'AB1201
AB-1201
AB1201-T
AB-12-01L1
AB1201-TER
AB1201 Transit
AB1201EFH
AB1201-02
AB1201-EFH';
my $regex = qr/^([a-zA-Z]{2}\d{4})(?!-\d)(L\d|Transit|T$)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}