import re
regex = re.compile(r"^([a-zA-Z]{2}\d{4})(?!-\d)(L\d|Transit|T$)?", flags=re.MULTILINE)
test_str = ("AB1201\n"
"AB-1201\n"
"AB1201-T\n"
"AB-12-01L1\n"
"AB1201-TER\n"
"AB1201 Transit\n"
"AB1201EFH\n"
"AB1201-02\n"
"AB1201-EFH")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")