using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z]{2}\d{4})(?!-\d)(L\d|Transit|T$)?";
string input = @"AB1201
AB-1201
AB1201-T
AB-12-01L1
AB1201-TER
AB1201 Transit
AB1201EFH
AB1201-02
AB1201-EFH";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}