re = /^([a-zA-Z]{2}\d{4})(?!-\d)(L\d|Transit|T$)?/m
str = 'AB1201
AB-1201
AB1201-T
AB-12-01L1
AB1201-TER
AB1201 Transit
AB1201EFH
AB1201-02
AB1201-EFH'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end