use strict;
my $str = 'CRT\\x00\\x00\\x00\\x00\\x00G3\\x00\\x00\\x00\\x00\\x00\\x00\\x80\\x10a\\x06\\x00\\x00\\x00\\x00\\x16@E\\x00\\x00\\x00\\x00\\x00\\x00\\x00\\x00\\x00\\x13';
my $regex = qr/(?!\\x\d\d)(.)|..(..)/p;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";