re = /(?!\\x\d\d)(.)|..(..)/
str = 'CRT\\x00\\x00\\x00\\x00\\x00G3\\x00\\x00\\x00\\x00\\x00\\x00\\x80\\x10a\\x06\\x00\\x00\\x00\\x00\\x16@E\\x00\\x00\\x00\\x00\\x00\\x00\\x00\\x00\\x00\\x13'
subst = '\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result