#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[a-zA-Z0-9]{8}(XXX)$)|(^[a-zA-Z0-9]{11}$)"
Local $sString = "Invalid:" & @CRLF & _
"Ah7AyXXX" & @CRLF & _
"ahs221ssXXX" & @CRLF & _
"aed3" & @CRLF & _
"" & @CRLF & _
"Valid:" & @CRLF & _
"Xg6tSSw3" & @CRLF & _
"ahs221sssws"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")