import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[a-zA-Z0-9]{8}(XXX)$)|(^[a-zA-Z0-9]{11}$)";
final String string = "Invalid:\n"
+ "Ah7AyXXX\n"
+ "ahs221ssXXX\n"
+ "aed3\n\n"
+ "Valid:\n"
+ "Xg6tSSw3\n"
+ "ahs221sssws";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}