re = /(^[a-zA-Z0-9]{8}(XXX)$)|(^[a-zA-Z0-9]{11}$)/m
str = 'Invalid:
Ah7AyXXX
ahs221ssXXX
aed3
Valid:
Xg6tSSw3
ahs221sssws'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end