const regex = /(^[a-zA-Z0-9]{8}(XXX)$)|(^[a-zA-Z0-9]{11}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[a-zA-Z0-9]{8}(XXX)$)|(^[a-zA-Z0-9]{11}$)', 'gm')
const str = `Invalid:
Ah7AyXXX
ahs221ssXXX
aed3
Valid:
Xg6tSSw3
ahs221sssws`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}