// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[a-zA-Z0-9]{8}(XXX)$)|(^[a-zA-Z0-9]{11}$)").unwrap();
let string = "Invalid:
Ah7AyXXX
ahs221ssXXX
aed3
Valid:
Xg6tSSw3
ahs221sssws";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}