$re = '/(^[a-zA-Z0-9]{8}(XXX)$)|(^[a-zA-Z0-9]{11}$)/m';
$str = 'Invalid:
Ah7AyXXX
ahs221ssXXX
aed3
Valid:
Xg6tSSw3
ahs221sssws';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);