using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[a-zA-Z0-9]{8}(XXX)$)|(^[a-zA-Z0-9]{11}$)";
string input = @"Invalid:
Ah7AyXXX
ahs221ssXXX
aed3
Valid:
Xg6tSSw3
ahs221sssws";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}