# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[(?=pid)([^\s]*)[^\]]*\]/\1/gm;t' <<< "Fri Apr 26 06:41:59 2019 [pid 5805] [user2] OK LOGIN: Client \"192.168.50.30\"
Fri Apr 26 07:12:00 2019 [pid 6809] [user4] OK LOGIN: Client \"192.168.50.34\""