import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(?=pid)([^\\s]*)[^\\]]*\\]";
final String string = "Fri Apr 26 06:41:59 2019 [pid 5805] [user2] OK LOGIN: Client \"192.168.50.30\" \n"
+ "Fri Apr 26 07:12:00 2019 [pid 6809] [user4] OK LOGIN: Client \"192.168.50.34\"";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}