$re = '/\[(?=pid)([^\s]*)[^\]]*\]/m';
$str = 'Fri Apr 26 06:41:59 2019 [pid 5805] [user2] OK LOGIN: Client "192.168.50.30"
Fri Apr 26 07:12:00 2019 [pid 6809] [user4] OK LOGIN: Client "192.168.50.34"';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;