#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[(?=pid)([^\s]*)[^\]]*\]"
Local $sString = "Fri Apr 26 06:41:59 2019 [pid 5805] [user2] OK LOGIN: Client "192.168.50.30" " & @CRLF & _
"Fri Apr 26 07:12:00 2019 [pid 6809] [user4] OK LOGIN: Client "192.168.50.34""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)