# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[(?=pid)([^\s]*)[^\]]*\]"
test_str = ("Fri Apr 26 06:41:59 2019 [pid 5805] [user2] OK LOGIN: Client \"192.168.50.30\" \n"
"Fri Apr 26 07:12:00 2019 [pid 6809] [user4] OK LOGIN: Client \"192.168.50.34\"")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.